Nie wyświetla przycisków

Pomoc przy instalacji oraz użytkowaniu phpBB 3.2.x. Forum nie służy do zgłaszania znalezionych błędów, innowacji lub problemów związanych ze stylami i rozszerzeniami.
Borys1
Posty: 8
Rejestracja: 03 listopada 2017, 22:04

Nie wyświetla przycisków

Post autor: Borys1 » 03 listopada 2017, 22:11

Witam, zainstalowałem właśnie najnowszą wersje phpbb 3.2.1 i nie wyświetla mi przycisków, jak to widać na zdjęciu poniżej:
przyciski.jpg
(17.25 KiB) Pobrany 19 razy
proszę o pomoc w rozwiązaniu problemu.

vader
Posty: 365
Rejestracja: 19 kwietnia 2015, 14:44
Lokalizacja: Kraków
Kontakt:

Re: Nie wyświetla przycisków

Post autor: vader » 04 listopada 2017, 09:36

Sprawdź w przeglądarce pod F12, czy nie ma jakichś błędów. Dodatkowo wyczyść folder cache (bufor).

Borys1
Posty: 8
Rejestracja: 03 listopada 2017, 22:04

Re: Nie wyświetla przycisków

Post autor: Borys1 » 07 listopada 2017, 21:19

Witam,
dziękuję za odpowiedź! Stronę próbowałem już otwierać za pomocą 3 różnych przeglądarek a także i przez telefon. Forum także instalowałem już kilkukrotnie. Pobierałem nawet ponownie pliki do instalacji ze strony phpbb.com i wciąż mam ten sam problem. Poprzednia wersja forum pracowała prawidłowo.
Niestety nie nadążam za rozwojem stron internetowych i nie ogarniam języków jakimi są one pisane, dlatego nie jestem w stanie samodzielnie sprawdzić poprawności ich treści.
Będę wdzięczny za kolejne sugestie.

vader
Posty: 365
Rejestracja: 19 kwietnia 2015, 14:44
Lokalizacja: Kraków
Kontakt:

Re: Nie wyświetla przycisków

Post autor: vader » 08 listopada 2017, 12:46

Styl jest w dobrej wersji - 3.2.1? Czy pliki są w dobrej lokalizacji?

wicy
Posty: 151
Rejestracja: 22 października 2010, 10:28

Re: Nie wyświetla przycisków

Post autor: wicy » 08 listopada 2017, 15:10

Sprawdź w pliku stylu icons.css (czy w ogóle masz ten plik?) jak zdefiniowany jest element .icon
Wygląda, ze brak wpisu font-family: FontAwesome;
_________
forgen.pl

Borys1
Posty: 8
Rejestracja: 03 listopada 2017, 22:04

Re: Nie wyświetla przycisków

Post autor: Borys1 » 09 listopada 2017, 21:55

Bardzo dziękuję za odpowiedzi.
Tak, całość jest w wersji 3.2.1
Po ściągnięciu i rozpakowaniu, zawartość pliku skopiowałem za pomocą filezilla na serwer, po czym dokonałem instalacji zakończonej sukcesem.
Plik icons.css znajduje się na serwerze w /styles/prosilver/theme i widnieje w nim podana fraza:
icons.jpg
(104.37 KiB) Pobrany 9 razy
Jeśli macie jeszcze jakieś pomysły to będę wdzięczny. Dziękuję za poświęcony przez Was czas.

wicy
Posty: 151
Rejestracja: 22 października 2010, 10:28

Re: Nie wyświetla przycisków

Post autor: wicy » 11 listopada 2017, 23:00

Może błąd leży w działaniu biblioteki jQuery. Zainstaluj sobie dowolne rozszerzenie korzystające z Ajax (jakiś shoutbox np.) i sprawdź poprawność jego działania. Jeśli będą błędy skieruj wzrok na obsługę javascript.
_________
forgen.pl

Borys1
Posty: 8
Rejestracja: 03 listopada 2017, 22:04

Re: Nie wyświetla przycisków

Post autor: Borys1 » 11 listopada 2017, 23:21

"wicy" dziękuję za Twoją odpowiedź. Biblioteki jQuery i javascript to dla mnie czarna magia.

Wydaje mi się jednak, że coś leży po stronie serwera. Zainstalowałem wczoraj forum na serwerze lokalnym XAMPP i wszystko działa prawidłowo. Te same pliki wykorzystałem do instalacji, którą wykonałem dzisiaj na serwerze SuperHost i znów pojawia się ten sam problem. Dziwi mnie to tym bardzie, że jakieś dwa miesiące temu wykonywałem tą samą instalacje na tym serwerze i wszystko działało prawidłowo.
Czy ma ktoś jeszcze jakieś sugestie?

Aviator
zespół
Posty: 2079
Rejestracja: 07 czerwca 2011, 22:14
Lokalizacja: ZS

Re: Nie wyświetla przycisków

Post autor: Aviator » 11 listopada 2017, 23:42

Możesz zainstalować forum i podać link.
-=Jeżeli w moim poście brakuje znaków diakrytycznych, oznacza to, że posta wyklepałem przez telefon=-

Borys1
Posty: 8
Rejestracja: 03 listopada 2017, 22:04

Re: Nie wyświetla przycisków

Post autor: Borys1 » 12 listopada 2017, 00:08


Borys1
Posty: 8
Rejestracja: 03 listopada 2017, 22:04

Re: Nie wyświetla przycisków

Post autor: Borys1 » 12 listopada 2017, 00:13

SuperHost również posiada instalator phpbb ale w starej wersji. Zainstalowałem i działa poprawnie:
http://www.ssc-baltic.eu/ssc-baltic.eu/
ale ta wersja jest kiepska.

vader
Posty: 365
Rejestracja: 19 kwietnia 2015, 14:44
Lokalizacja: Kraków
Kontakt:

Re: Nie wyświetla przycisków

Post autor: vader » 12 listopada 2017, 09:01

Mówiłeś że w konsoli przeglądarki nie ma żadnych błędów a są: https://github.com/martndemus/ember-fon ... /issues/71

wicy
Posty: 151
Rejestracja: 22 października 2010, 10:28

Re: Nie wyświetla przycisków

Post autor: wicy » 12 listopada 2017, 11:16

Borys, zmień w tabeli config allow_cdn na 0. Powinien wtedy ładować fonty z lokalnego folderu forum\assets (o ile taki jest, ale w paczce 3.2.1 powinien być).

Sorry, nie zauważyłem w konsoli, że właśnie lokalnie nie pobiera fontu. W takim razie zmień allow_cdn na 1, coby pobrał sobie fonta z url.

Jeśli i to nie pomoże, to już pozostaje kwestia konfiguracji serwera po stronie hostingu i pisanie do admina.
_________
forgen.pl

vader
Posty: 365
Rejestracja: 19 kwietnia 2015, 14:44
Lokalizacja: Kraków
Kontakt:

Re: Nie wyświetla przycisków

Post autor: vader » 12 listopada 2017, 12:22

Ewentualnie sprawdzić uprawnienia folderu/pliku. Moze jakimś cudem, nie ma uprawnień do odczytu?

Borys1
Posty: 8
Rejestracja: 03 listopada 2017, 22:04

Re: Nie wyświetla przycisków

Post autor: Borys1 » 12 listopada 2017, 21:56

"vader" - faktycznie nie sprawdziłem tych błędów, bo nawet nie wiedziałem, że można. To dla mnie nowość. Tak samo nie wiem jak sprawdzić uprawnienia plików. Dzięki Wam zdobywam nową wiedzę.
Załączam screeny z plików config i allow - szczerze pisząc nie wiem w którym wierszu mam zmienić wartości o których pisze "wicy".
config.jpg
(171.46 KiB) Pobrany 5 razy
allow.jpg
(194.18 KiB) Pobrany 5 razy
Napisałem również wiadomość do SuperHost. Może to faktycznie coś po ich stronie jest nie tak.
Dziękuję za Wasze odpowiedzi i czas jaki dla mnie poświęcacie.

ODPOWIEDZ