Niedochodzące maile

mpaw
Posty: 31
Rejestracja: 05 września 2019, 15:40

Niedochodzące maile

Post autor: mpaw » 05 marca 2020, 10:16

Dzień dobry

Mam problem z niedochodzeniem maili m. in. z linkami aktywacyjnymi.

Dostaję taki log: LOG_ERROR_EMAIL

Kod: Zaznacz cały

EMAIL/SMTP
/ucp.php

Nie można otrzymać kodów odpowiedzi serwera.
Backtrace
Connecting to mail.kxxxxxxxx:25
LINE: 1096 <- 220 mail.axxxxxx ESMTP
# EHLO xxxxxxx
LINE: 1443 <- 250-mail.axxxxx
LINE: 1443 <- 250-PIPELINING
LINE: 1443 <- 250-SIZE 11534336
LINE: 1443 <- 250-ETRN
LINE: 1443 <- 250-STARTTLS
LINE: 1443 <- 250-AUTH PLAIN LOGIN
LINE: 1443 <- 250-AUTH=PLAIN LOGIN
LINE: 1443 <- 250-ENHANCEDSTATUSCODES
LINE: 1443 <- 250-8BITMIME
LINE: 1443 <- 250 DSN
# STARTTLS
LINE: 1488 <- 220 2.0.0 Ready to start TLS
# AUTH LOGIN
Czy można na podstawie tego logu stwierdzić, co jest nie tak?

Dzięki
Michał

vader
Moderator
Posty: 1067
Rejestracja: 19 kwietnia 2015, 14:44
Lokalizacja: Kraków
Kontakt:

Re: Niedochodzące maile

Post autor: vader » 05 marca 2020, 11:24

Cześć,

Do tej pory działało? Coś zmieniłeś w ustawieniach lub zmieniło się w infrastrukturze serwera/smtp?

mpaw
Posty: 31
Rejestracja: 05 września 2019, 15:40

Re: Niedochodzące maile

Post autor: mpaw » 05 marca 2020, 12:15

Ja nic nie zmieniałem. Właściciel serwera zgłosił mi, że od jakiegoś czasu maile z potwierdzeniem i inne wiadomości z forów nie dochodzą.

mpaw
Posty: 31
Rejestracja: 05 września 2019, 15:40

Re: Niedochodzące maile

Post autor: mpaw » 05 marca 2020, 14:53

Doszukałem się w logach. Błędy zaczęły się pojawiać w końcówce sierpnia 2019 i od tego czasu się skopało. Mam tylko pytanie: do jakich linii odnoszą się komunikaty

Kod: Zaznacz cały

LINE: 1096
LINE: 1443
etc.

w jakim pliku mam szukać tych linii?

vader
Moderator
Posty: 1067
Rejestracja: 19 kwietnia 2015, 14:44
Lokalizacja: Kraków
Kontakt:

Re: Niedochodzące maile

Post autor: vader » 06 marca 2020, 09:13

Korzystasz z SMTP przy wysyłaniu emaili czy e-mail przez witrynę? Sprawdź też port, bo może 25 jest blokowany. Ustaw 587 lub 465 (SSL).

Podrzuć screen ustawień, będzie szybciej: ACP > Komunikacja > Ustawienia e-maili

mpaw
Posty: 31
Rejestracja: 05 września 2019, 15:40

Re: Niedochodzące maile

Post autor: mpaw » 07 marca 2020, 08:31

smtp.png
smtp
(55.38 KiB) Pobrany 27 razy

vader
Moderator
Posty: 1067
Rejestracja: 19 kwietnia 2015, 14:44
Lokalizacja: Kraków
Kontakt:

Re: Niedochodzące maile

Post autor: vader » 07 marca 2020, 09:27

Zmień port 25 na 465 i wyślij testowy email. Tam poniżej screenu masz więcej opcji. Jak je masz zaznaczone?

Możesz też spróbować odznaczyć SMTP = Nie. A zaznaczyć wyślij email orzez witrynę i przetestuj.

Wielkość pakietu zmień na 0.

mpaw
Posty: 31
Rejestracja: 05 września 2019, 15:40

Re: Niedochodzące maile

Post autor: mpaw » 07 marca 2020, 17:56

Mam problem. Założyłem konto na gmailu. Jak mam skonfigurować wysyłanie maili, żeby cokolwiek dochodziło? I na jaki adres przyjdzie mail testowy?

dzięki Michał

ODPOWIEDZ