Tag [S] w temacie powoduje problem w PW

Pomoc przy instalacji oraz użytkowaniu phpBB 3.2.x. Forum nie służy do zgłaszania znalezionych błędów, innowacji lub problemów związanych ze stylami i rozszerzeniami.
rajpfpbb
Posty: 25
Rejestracja: 11 stycznia 2018, 09:36

Tag [S] w temacie powoduje problem w PW

Post autor: rajpfpbb » 02 kwietnia 2018, 07:48

Mamy na forum giełdę. W tematach sprzedażowych ludzie zamieszczają "[ S ]" jako oznaczenie sprzedaży.
Niestety jeżeli ktoś wyśle PW spod takiego tematu to w pw od razu jest url do tematu tematu.
np.

Kod: Zaznacz cały

[url =http://gry-planszowe.pl/forum/viewtopic.php?p=1028207#p1028207]Tytuł: [S] Dracula 3ed (pomalowane figurki), TS:Tajemnica Maski, TS:Endurance, Pan Tu Nie Stał[/url]
Wtedy system traktuje takie [ S ] jako otwarcie tagu i przekreśla całą wiadomość w pw.

Oczywiste rozwiązanie to wyłączenie BBCode w pw, ale wtedy nie będzie działać żaden tag w pw (w tym quote i url).
Inna opcja to wyłączenie taga [ s ] na forum - bo przecież jest zdefiniowany jako dodatkowy.

Obu tych opcji wolałbym uniknąć. Znacie inne rozwiązanie?
(można ludziom napisać żeby nie używali [ S ] albo je kasowali w pw, ale zawsze będą tacy którzy tego nie zrobią/nie przeczytają/nie zrozumieją i będą marudzić).

vader
Moderator
Posty: 584
Rejestracja: 19 kwietnia 2015, 14:44
Lokalizacja: Kraków
Kontakt:

Re: Tag [S] w temacie powoduje problem w PW

Post autor: vader » 02 kwietnia 2018, 08:41

Spróbuj użyć tagu [/s] jako tymczasowe rozwiązanie.

rajpfpbb
Posty: 25
Rejestracja: 11 stycznia 2018, 09:36

Re: Tag [S] w temacie powoduje problem w PW

Post autor: rajpfpbb » 02 kwietnia 2018, 08:55

Na jakiej zasadzie? Jak to miałoby działać?

vader
Moderator
Posty: 584
Rejestracja: 19 kwietnia 2015, 14:44
Lokalizacja: Kraków
Kontakt:

Re: Tag [S] w temacie powoduje problem w PW

Post autor: vader » 02 kwietnia 2018, 13:15

Taki tag, może być traktowany jako od razu zamknięty

rajpfpbb
Posty: 25
Rejestracja: 11 stycznia 2018, 09:36

Re: Tag [S] w temacie powoduje problem w PW

Post autor: rajpfpbb » 03 kwietnia 2018, 08:46

Nie jestem pewien jak to [/s] powinno być skonfigurowane, ale dostałem inną podpowiedź, która rozwiązała problem:

Kod: Zaznacz cały

[s $forceLookahead=true]{TEXT}[/s]
Z tym parametrem tag jest uwzględniany tylko wtedy gdy występuje tag kończący.

ODPOWIEDZ