Nie wyświetla przycisków

Pomoc przy instalacji oraz użytkowaniu phpBB 3.2.x. Forum nie służy do zgłaszania znalezionych błędów, innowacji lub problemów związanych ze stylami i rozszerzeniami.
wicy
Posty: 158
Rejestracja: 22 października 2010, 10:28

Re: Nie wyświetla przycisków

Post autor: wicy » 12 listopada 2017, 22:13

Do adminowana phpbb3 niezbędny jest dostęp do baz danych przez phpmyadmin. Zapewne go masz, więc w bazach sprawdź tabelę _config, znajdź wiersz z wartością allow_cdn, napisz jaką ma wartość. Spróbuj zamienić wartości 0<->1 i zobaczyć efekt. Niestety nie wiem, co w PA odpowiada za to ustawienie i jak się do niego dobrać z poziomu PA bez wchodzenia w bazy.

Drugą rzeczą niezbędną adminowi jest program przeszukujący pliki po zadanym tekście ;) Ja używam akurat HDS.exe. Możesz sprawdzić występowanie "awesome". Pojawia się ono w functions.php, gdzie generuje zmienną odpowiedzialną za odwołanie do plików fontów (lokalnie lub z url). Można testowo zmienić występujący tam warunek (pomijając zmienną allow_cdn) i na sztywno ustawić url dla fontu awesome.
Podane pliki config i allow nie mają nic do rzeczy.
_________
forgen.pl

Borys1
Posty: 8
Rejestracja: 03 listopada 2017, 22:04

Re: Nie wyświetla przycisków

Post autor: Borys1 » 13 listopada 2017, 20:34

"wicy" jak i pozostali forumowicze - bardzo Wam dziękuję za wszystkie podpowiedzi i za uwagą jaką mi poświęciliście. Posiadacie bardzo dużą wiedzę, którą dzielicie się z innymi, a to świadczy o Waszym wewnętrznym bogactwie.
Problem okazał się dla mnie na tyle skomplikowany, że nawet Wasze podpowiedzi okazały się za trudne dla takiego laika jak ja.
Sugerując się, że problem może leżeć po stronie hostingu (bo na lokalnym serwerze wszystko działało) wysłałem zapytanie do pracowników Superhostu. A oto odpowiedź jaką otrzymałem:

Przeglądarka wyrzucała błędy związane z dekodowaniem plików z katalogu assets/fonts.

Podmieniliśmy Panu w drodze wyjątku w/w pliki w katalogu strony na na pliki z pobranej paczki z CMSem phpBB3.

Na chwilę obecną problem został rozwiązany.

Zaznaczam również, że nie był to problem związany z błędnym funkcjonowaniem serwera.


Jeszcze raz dziękuję i pozdrawiam!

ODPOWIEDZ