phpbb-dodawanie rozszerzeń nie chce mi działać

Pomoc przy instalacji i konfiguracji rozszerzeń do phpBB 3.1.x.. Dyskusje na ich temat oraz baza dodatków i spolszczeń.
rafaeljohn
Posty: 9
Rejestracja: 07 sierpnia 2016, 15:07

phpbb-dodawanie rozszerzeń nie chce mi działać

Post autor: rafaeljohn » 20 sierpnia 2016, 12:45

Witam, zaczynam dopiero poznawać ten skrypt, potrzebuję dodać kilka rozszerzeń do mojego forum, przeczytałem, że rozszerzenia trzeba umieścić w folderze ext i tak zrobiłem i nic, pobrałem kompatybilne z obecną wersją 3.1.9 i dalej nic, co robię źle ???
Załączniki
Bez nazwy-2.jpg
(232.3 KiB) Pobrany 10778 razy
error-1.jpg
(81.21 KiB) Pobrany 10777 razy

Aviator
Administrator
Posty: 2083
Rejestracja: 07 czerwca 2011, 22:14
Lokalizacja: ZS

Re: phpbb-dodawanie rozszerzeń nie chce mi działać

Post autor: Aviator » 20 sierpnia 2016, 13:21

-=Jeżeli w moim poście brakuje znaków diakrytycznych, oznacza to, że posta wyklepałem przez telefon=-

Awatar użytkownika
all4phone
Posty: 60
Rejestracja: 20 lipca 2012, 10:30
Kontakt:

Re: phpbb-dodawanie rozszerzeń nie chce mi działać

Post autor: all4phone » 21 sierpnia 2016, 17:36

Wypakowane archiwum, czyli movetopiscwhenlocked powinieneś umieścić w folderze kasimi a dokładnie:
ext/kasimi/movetopiscwhenlocked/_tutaj_pliki_i_foldery_rozszerzeenia

rafaeljohn
Posty: 9
Rejestracja: 07 sierpnia 2016, 15:07

Re: phpbb-dodawanie rozszerzeń nie chce mi działać

Post autor: rafaeljohn » 22 sierpnia 2016, 00:58

super dzięki, teraz to już jest dla mnie jasne dzięki.
Przy okazji chce zrobić przyjazne linki a nie jak jest tutaj "viewforum.php?f=3" udało mi się odnaleźć do tego rozszerzenie ale brakuje mi:
phpBB_SEO_Ultimate_SEO_URL_v0.7.0, z tego wynika że brakuję mi:
ext/?????/phpBB_SEO_Ultimate_SEO_URL_v0.7.0/pliki-i-foldery

Awatar użytkownika
Zyleta
Moderator
Posty: 196
Rejestracja: 03 marca 2014, 15:39

Re: phpbb-dodawanie rozszerzeń nie chce mi działać

Post autor: Zyleta » 22 sierpnia 2016, 19:15

Poprawna ścieżka to nie phpBB_SEO_Ultimate_SEO_URL_v0.7.0 - to nie jest prawidłowa nazwa tego rozszerzenia - to jest nazwa robocza.

Prawidłowa nazwa znajduje się w pliku composer.json pod nazwą "name" ( "name": "phpbbseo/usu",). Dołączając do tego folder ext, będzie pełna ścieżka w której musi znaleźć się plik composer.json.

Zatem pełna ścieżka jaką będziesz mieć to: ext/phpbbseo/usu/ (a w tej ścieżce będą wszystkie pliki i foldery z tego rozszerzenia, czyli ścieżka do wcześniej wymienionego pliku .json będzie następująca: ext/phpbbseo/usu/composer.json

rafaeljohn
Posty: 9
Rejestracja: 07 sierpnia 2016, 15:07

Re: phpbb-dodawanie rozszerzeń nie chce mi działać

Post autor: rafaeljohn » 22 sierpnia 2016, 20:47

a jak takiego pliku tam nie ma "composer.json"
Chodzę po forach zrobionych przy pomocy tego skryptu phpbb i widzę że nikt nie korzysta z przyjaznych linków.

Awatar użytkownika
Zyleta
Moderator
Posty: 196
Rejestracja: 03 marca 2014, 15:39

Re: phpbb-dodawanie rozszerzeń nie chce mi działać

Post autor: Zyleta » 22 sierpnia 2016, 22:20

Jeśli nie ma w tym "rozszerzeniu" SEO pliku composer.json, to znaczy że nie jest to rozszerzenie. Przynajmniej nie do wersji phpBB 3.1.x ani 3.2.x, bo w tym pliku są właśnie wszelkie informacje odnośnie tego rozszerzenia i to z niego skrypt pobiera niezbędne dane do instalacji rozszerzenia.

Możliwe, że przez pomyłkę pobrałeś wersję pod 3.0, albo jakiś inny skrypt forum (albo źle patrzysz).

Jeśli pobrałeś to rozszerzenie z tego forum ( viewtopic.php?f=124&t=17367&p=74326#p73391 z załącznika), to po rozpakowaniu tej paczki miałeś folder phpbbseo, w nim usu, w którym z kolej były pliki i foldery rozszerzenia, wśród nich właśnie composer.json
Ogólnie, po rozpakowaniu, wystarczyłoby żebyć folder phpbbseo (z całą zawartością - tak aby w środku folderu phpbbseo był katalog usu, a w nim pliki i foldery tego rozszerzenia) skopiował do katalogu ext i potem włączył go w panelu administratora (zakładka dostosowywanie).

Jeśli pobierałeś z innego źródła - możliwe że pobrałeś nie tę wersję co potrzeba

rafaeljohn
Posty: 9
Rejestracja: 07 sierpnia 2016, 15:07

Re: phpbb-dodawanie rozszerzeń nie chce mi działać

Post autor: rafaeljohn » 23 sierpnia 2016, 00:03

super dzięki, faktycznie pobrałem nie tą wersję....
teraz tylko będę musiał się pobawić ustawieniami, żeby nic nie zepsuć...
a jest jakiś manual do tego, żeby prawidłowo skonfigurować opcje w tym skrypcie...

Bohun
Posty: 6
Rejestracja: 30 grudnia 2013, 22:26

Re: phpbb-dodawanie rozszerzeń nie chce mi działać

Post autor: Bohun » 24 sierpnia 2016, 06:45

Skorzystałem na podpowiedziach "Żylety" dla Ciebie. A potem z kolei wykorzystałem te rady - http://blogkomp.pl/optymalizacja-seo-phpbb3/ Poszukaj też cz. 2.

rafaeljohn
Posty: 9
Rejestracja: 07 sierpnia 2016, 15:07

Re: phpbb-dodawanie rozszerzeń nie chce mi działać

Post autor: rafaeljohn » 09 września 2016, 00:10

niestety link przestał działać, a nawet że całą strona nie działa http://blogkomp.pl/optymalizacja-seo-phpbb3/

ODPOWIEDZ