Instalacja czystego phpBB 3.1 - błędy

Pomoc przy instalacji oraz użytkowaniu phpBB 3.1.x. Forum nie służy do zgłaszania znalezionych błędów, innowacji lub problemów związanych ze stylami i modyfikacjami.
maju
Posty: 2
Rejestracja: 04 listopada 2014, 11:23

Instalacja czystego phpBB 3.1 - błędy

Post autor: maju » 05 listopada 2014, 13:21

Witam

Podczas instalacji czystego forum w wersji 3.1.1 (czyli obecnie najnowsza) pojawiają się błędy.

1.
Objawy:
Na początku instalki widać tylko czysty ekran - tak jakby plik index był czysty.
Rozwiązanie:
Pomogła zmiana wersji php na serwerze - przełączyłem z serii 3.2 na 3.3
ale
2.
Wyskakuje komunikat:

Kod: Zaznacz cały

Fatal error: Class 'Twig_Node' not found in /forum31/vendor/twig/twig/lib/Twig/Node/Expression.php on line 19
Specjalistą od php nie jestem ale po mojemu jest tam tylko jedna komenda:

Kod: Zaznacz cały

abstract class Twig_Node_Expression extends Twig_Node
Pytanie:
Co jeszcze jest nie tak?
Obecnie instalka nie idzie dalej.

Awatar użytkownika
daroPL
Zasłużony
Posty: 4564
Rejestracja: 24 czerwca 2005, 13:36
Lokalizacja: Poznań
Kontakt:

Re: Instalacja czystego phpBB 3.1 - błędy

Post autor: daroPL » 05 listopada 2014, 18:02

Wygląda to na jakiś problem z autoloaderem. Jaką masz wersję PHP zainstalowaną na serwerze? Wygląda na to, że starszą niż PHP 5.1. Dla działania phpBB potrzeba teraz PHP w wersji 5.3.3, a najlepiej to co najmniej PHP 5.4.4.

maju
Posty: 2
Rejestracja: 04 listopada 2014, 11:23

Re: Instalacja czystego phpBB 3.1 - błędy

Post autor: maju » 07 listopada 2014, 08:18

daroPL pisze: Jaką masz wersję PHP zainstalowaną na serwerze? Wygląda na to, że starszą niż PHP 5.1. Dla działania phpBB potrzeba teraz PHP w wersji 5.3.3, a najlepiej to co najmniej PHP 5.4.4.
Na serwerze mam do wyboru:
PHP w wersji 5.2.17, 5.3.27, 5.4.24 oraz 5.5.9,

W oknie wyboru podają tylko dwie pierwsze cyfry, czyli skoro obecnie wybrałem 5.3 to znaczy, że mam 5.3.27.
Pisałem o tym w pierwszym poście ale z błędem - wpisałem 3 zamiast 5tki.
Mam więc 5.3.27 - powinno więc działać.
Owszem mogę wybrać jeszcze nowszą wersję php ale wówczas przestaje działać działające forum 3.0.

Chce postawić nowe forum obok dotychczasowego, potestować, dostosować pod siebie i dopiero wówczas oddać do użytku.
Tak więc wyłączenie dotychczasowego forum to nie jest dobry pomysł.

Może ktoś ma pomysł jak ten błąd przy instalalacji obejść...

feniks01
Posty: 5
Rejestracja: 09 grudnia 2014, 23:46

Re: Instalacja czystego phpBB 3.1 - błędy

Post autor: feniks01 » 10 grudnia 2014, 00:05

Witam,

Mam podobny problem. Aby nie zakładać nowego tematu napiszę tutaj.

Również mam problem z czystą instalacją forum. Zaraz po niej w PA pojawiają się błędy typu Warning. Podsyłam screena, aby lepiej zobrazlwać problem:
http://s5.ifotos.pl/img/Bez-nazwy_whsnnee.jpg

Próbowałem zainstalować AutoMOD, ale nie mogę, więc na obrazku jest informacja z prośbą o usunięcie pliku install z katalogu forum.

Pls, pomocy, co mogę zrobić?

Moje forum obsługuje wersje 5.4 PHP.

Pozdrawiam serdecznie,
Damian. Nowy użytkownik forum :-)

feniks01
Posty: 5
Rejestracja: 09 grudnia 2014, 23:46

Re: Instalacja czystego phpBB 3.1 - błędy

Post autor: feniks01 » 11 grudnia 2014, 16:03

Jakieś porady?

Awatar użytkownika
Apatryda
Posty: 10
Rejestracja: 09 lutego 2014, 09:02
Kontakt:

Re: Instalacja czystego phpBB 3.1 - błędy

Post autor: Apatryda » 17 lutego 2015, 18:12

Witam
Mam również problem z zainstalowaniem forum phpBB-3.1.3-pl (pobrany z phpbb.pl) niestety po wrzuceniu plików na serwer, następnie wpisaniu w przeglądarce adresu swojej strony http://www.moja_strona.pl otrzymuje taki komunikat: patrz załączony zrzut ekranu. Dodatkowo załączam podstawowe ustawienia serwera, proszę o pomoc, nie mam pojęcia jak mam zainstalować forum.
Pozdrawiam
Załączniki
cats.jpg
(69.28 KiB) Pobrany 3051 razy

Awatar użytkownika
Bielu
Zasłużony
Posty: 512
Rejestracja: 17 marca 2011, 07:49
Kontakt:

Re: Instalacja czystego phpBB 3.1 - błędy

Post autor: Bielu » 17 lutego 2015, 20:44

przekopiuj te liniki co ci wypluwa to może coś pomogę :)
Uwaga! pomoc poza forum jest odpłatna!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Pomogłem? Podziękuj, dając like: https://www.facebook.com/webdeveloperbielu
=====================
Kodowanie styli, modowanie phpbb3 oraz innych skryptów: Webdeveloper Bielu

Awatar użytkownika
Apatryda
Posty: 10
Rejestracja: 09 lutego 2014, 09:02
Kontakt:

Re: Instalacja czystego phpBB 3.1 - błędy

Post autor: Apatryda » 18 lutego 2015, 09:55

Problem rozwiązany
Dziękuję za chęć pomocy...

Aviator
Administrator
Posty: 2089
Rejestracja: 07 czerwca 2011, 22:14
Lokalizacja: ZS

Re: Instalacja czystego phpBB 3.1 - błędy

Post autor: Aviator » 18 lutego 2015, 21:08

Apatryda pisze:Problem rozwiązany
Dziękuję za chęć pomocy...
Bardzo nas to cieszy, ale mógłbyś się podzielić rozwiązaniem dla potomnych
-=Jeżeli w moim poście brakuje znaków diakrytycznych, oznacza to, że posta wyklepałem przez telefon=-

Awatar użytkownika
Apatryda
Posty: 10
Rejestracja: 09 lutego 2014, 09:02
Kontakt:

Re: Instalacja czystego phpBB 3.1 - błędy

Post autor: Apatryda » 27 lutego 2015, 13:43

Problem rozwiązałem tak:
W pierwszej linijce w (.htaccess) wpisałem polecenie:

Kod: Zaznacz cały

AddHandler php5.3-fastcgi php
Powinno wyglądać tak:
http://i61.tinypic.com/2zoeu4g.jpg
i to rozwiązało mój problem z instalacją najnowszej wersji PHPBB 3.1.3 pl
PS: Opisany sposób zadziałał na hostingu webd.pl tam mam swoje konto, na innych nie mam pojęcia czy zadziała.

ODPOWIEDZ