Problem z tagiem video na stronie

Forum poświęcone skryptom, językom programowania, serwerom i hostingowi, domenom itp.
Seysso
Posty: 1
Rejestracja: 18 kwietnia 2020, 15:30

Problem z tagiem video na stronie

Post autor: Seysso » 18 kwietnia 2020, 15:32

Witam, mam problem na swojej stronie z tagiem video.
Korzystając na stronie z BBCode użycie tagu video jest możliwe tylko raz. Użycie wielokrotne powoduje wyłącznie wyświetlenie ostatniego użycia, a wszystko co było użyte przed tagiem znika.

Kod odpowiedzialny za tag to:

$s = preg_replace("/[video=[^\s'\"<>]youtube.com.v=([^\s'\"<>]+)]/ims", "<object width=\"500\" height=\"410\"><param name=\"movie\" value=\"https://www.youtube.com/v/\1\"></param><embed src=\"https://www.youtube.com/v/\1\" type=\"application/x-shockwave-flash\" width=\"500\" height=\"410\"></embed></object>", $s);
// Google Vids
$s = preg_replace("/[video=[^\s'\"<>]video.google.com.docid=(-?[0-9]+).*]/ims", "<embed style=\"width:500px; height:410px;\" id=\"VideoPlayback\" align=\"middle\" type=\"application/x-shockwave-flash\" src=\"https://video.google.com/googleplayer.swf?docId=\1\" allowScriptAccess=\"sameDomain\" quality=\"best\" bgcolor=\"#ffffff\" scale=\"noScale\" wmode=\"window\" salign=\"TL\" FlashVars=\"playerMode=embedded\"> </embed>", $s);

Czy ktoś pomoże to poprawić ?

vader
Moderator
Posty: 1069
Rejestracja: 19 kwietnia 2015, 14:44
Lokalizacja: Kraków
Kontakt:

Re: Problem z tagiem video na stronie

Post autor: vader » 20 kwietnia 2020, 14:47

A po co się bawić we własne BBcode jak są gotowe rozwiązania? https://www.phpbb.com/customise/db/exte ... ediaembed/

ODPOWIEDZ