Jumpbox generuje niedziałające URLe

Pomoc przy instalacji oraz użytkowaniu phpBB 3.1.x. Forum nie służy do zgłaszania znalezionych błędów, innowacji lub problemów związanych ze stylami i modyfikacjami.
Sexting.pl
Posty: 3
Rejestracja: 24 marca 2018, 20:08

Jumpbox generuje niedziałające URLe

Post autor: Sexting.pl » 24 marca 2018, 20:45

Cześć!

Niestety nie mogę sobie poradzić z pewnym problemem w 3.1.9.
GSC zwraca mi już od dawna błędne URLe z Jumpboxa (Funkcja Przejdź do...) wewnątrz forum - faktycznie - generuje złe URLe.
Nie wiem szczerze mówiąc w czym problem, ale generuje URLe w stylu: http://sexting.pl/forum/0?f=16
zamiast: http://sexting.pl/forum/viewforum.php?f=16

Jak mogę powyższy problem skutecznie rozwiązać?
Przeglądając pliki typu: viewforum.php - jumpbox jest chyba poprawnie wywołany: make_jumpbox(append_sid("{$phpbb_root_path}viewforum.$phpEx"), $forum_id);

Adres forum: forum Sexting.pl

Będę niezmiernie wdzięczny za pomoc.
Pozdrawiam!

vader
Moderator
Posty: 647
Rejestracja: 19 kwietnia 2015, 14:44
Lokalizacja: Kraków
Kontakt:

Re: Jumpbox generuje niedziałające URLe

Post autor: vader » 25 marca 2018, 08:18

Czy coś się stało konkretnego, że przestało działać?

Były jakieś zmiany na serwerze/zmiany ustawień forum/zainstalowano nowe rozszerzenie/zmiany w pliku .htaccess?

Sexting.pl
Posty: 3
Rejestracja: 24 marca 2018, 20:08

Re: Jumpbox generuje niedziałające URLe

Post autor: Sexting.pl » 25 marca 2018, 12:56

Błąd został wychwycony przez Google Search Console z pewnym opóźnieniem, ale trudno mi powiedzieć czy omyłkowo coś sam zepsułem.

Ustawienia forum - jasne, ale nie działałem nic związanego z URLami.
Nie instalowałem nowych rozszerzeń.
Jeśli chodzi o .htaccess, tylko reguła przekierowań 301.

Zastanawiam się, w których plikach na serwerze szukać odpowiedzi, bo zakładam, że coś tam się zadziało. Komenda wywołania jumpboxa w plikach viewforum, viewtopic itd. jest taka sama - poprawna.

vader
Moderator
Posty: 647
Rejestracja: 19 kwietnia 2015, 14:44
Lokalizacja: Kraków
Kontakt:

Re: Jumpbox generuje niedziałające URLe

Post autor: vader » 25 marca 2018, 19:48

Czy jumpobx działa tak samo źle w każdym miejscu forum czy tylko na konkretnej stronie? Może był jakiś bug. Dla pewności sprawdź logi serwera oraz w przeglądarce. Przydałoby się jakieś testowe konto na twoje forum.

Nie myślałeś o aktualizacji forum do phpBB 3.1.12 lub najlepiej 3.2.2?

Sexting.pl
Posty: 3
Rejestracja: 24 marca 2018, 20:08

Re: Jumpbox generuje niedziałające URLe

Post autor: Sexting.pl » 01 kwietnia 2018, 19:09

Dziękuję za zainteresowanie tematem.

Działa tak samo źle wszędzie generując takie same URLe.
Nie mogę się doszukać żadnej informacji, która mówiłaby coś na ten temat.

Testowe konto założyłem:
Zapraszam - testowejumpbox
Hasło: testowe

Hmm... Ok, bardzo chętnie dokonałbym aktualizacji, ale... Czy wtedy pojedyncze drobne edycje kodu, które robiłem na samym początku istnienia, zostaną zresetowane?

vader
Moderator
Posty: 647
Rejestracja: 19 kwietnia 2015, 14:44
Lokalizacja: Kraków
Kontakt:

Re: Jumpbox generuje niedziałające URLe

Post autor: vader » 01 kwietnia 2018, 19:15

Musisz jeszcze aktywować konto tego użytkownika.

Na 90% styl nie będzie działać. Trzeba by sprawdzić. To zachęcam chociaż zaktualizować do 3.1.12

ODPOWIEDZ