Forum nie czyta nieoficjalnych rozszerzeń.

Pomoc w przypadku kłopotów z rozszerzeniami: instalacją, konfiguracją, błędami. Zakładając nowy temat pamiętaj o odpowiednim prefiksie!
welli27
Posty: 9
Rejestracja: 06 stycznia 2018, 04:07
Lokalizacja: Żywiec

Forum nie czyta nieoficjalnych rozszerzeń.

Post autor: welli27 » 06 stycznia 2018, 04:14

Witam, piszę z prośbą, ponieważ próbuję rozwiązać problem swojego forum od 3 nocy. Na żadnym forum, nawet zagranicznym nie znalazłem odpowiedzi, dlatego piszę ten temat.

Wersja phpbb: 3.2.1
Wersja php: 5.6.33

Problem polega na tym, że Panelu Administratora wyświetlają się tylko oficjalne rozszerzenia phpbb ze strony: https://www.phpbb.com/extensions/official-extensions/

Jednakże rozszerzenia będące nieoficjalnymi, nie wyświetlają się w Panelu Administratora (nie da się ich zainstalować).

Wszystko dobrze instaluję z prawidłowymi wersjami.

W czym może być problem?

Z góry dziękuję za pomoc i pozdrawiam Marcin.

vader
Moderator
Posty: 584
Rejestracja: 19 kwietnia 2015, 14:44
Lokalizacja: Kraków
Kontakt:

Re: Forum nie czyta nieoficjalnych rozszerzeń.

Post autor: vader » 06 stycznia 2018, 08:14

Podeślij takie rozszerzenie.

welli27
Posty: 9
Rejestracja: 06 stycznia 2018, 04:07
Lokalizacja: Żywiec

Re: Forum nie czyta nieoficjalnych rozszerzeń.

Post autor: welli27 » 06 stycznia 2018, 09:31


vader
Moderator
Posty: 584
Rejestracja: 19 kwietnia 2015, 14:44
Lokalizacja: Kraków
Kontakt:

Re: Forum nie czyta nieoficjalnych rozszerzeń.

Post autor: vader » 06 stycznia 2018, 12:06

Mimo wszystko zapytam, jak wygląda ścieżka do folderu mchat czy ajaxchat?

welli27
Posty: 9
Rejestracja: 06 stycznia 2018, 04:07
Lokalizacja: Żywiec

Re: Forum nie czyta nieoficjalnych rozszerzeń.

Post autor: welli27 » 06 stycznia 2018, 12:34

mchat - ext/phpbb/dmzx/mchat
ajax - ext/phpbb/ajaxchat-master (samego "ajaxchat" też próbowałem)
steam - ext/phpbb/stevotvr/steamstatus

Reszta oficjalnych rozszerzeń w folderze ext/phpbb

vader
Moderator
Posty: 584
Rejestracja: 19 kwietnia 2015, 14:44
Lokalizacja: Kraków
Kontakt:

Re: Forum nie czyta nieoficjalnych rozszerzeń.

Post autor: vader » 06 stycznia 2018, 16:00

I tu jest problem :) Pamiętaj, aby ścieżka do rozszerzenie było zawsze w formacie /ext/autor_rozszerzenia/folder_rozszerzenia.

Czyli ma być:

mchat - ext/dmzx/mchat
ajax - ext/???/ajaxchat-master (nie wiem, kto jest autorem, dlatego dałem /???/)
steam - ext/stevotvr/steamstatus

welli27
Posty: 9
Rejestracja: 06 stycznia 2018, 04:07
Lokalizacja: Żywiec

Re: Forum nie czyta nieoficjalnych rozszerzeń.

Post autor: welli27 » 06 stycznia 2018, 17:24

Hymm, już próbowałem tej ścieżki. Ale spróbowałem jeszcze dwa razy dla pewności. I muszę powiedzieć za drugim podejściem zaskoczyło. Nie wiem w czym był problem, ale ważne, że już działa :D

Bardzo ślicznie dziękuję za pomoc i pozdrawiam.

Temacik do zamknięcia.

Awatar użytkownika
Don Vito
Posty: 2
Rejestracja: 24 stycznia 2017, 09:26
Kontakt:

Re: Forum nie czyta nieoficjalnych rozszerzeń.

Post autor: Don Vito » 20 stycznia 2018, 22:17

Sprawdź jak jest zapisana ścieżka w composer.json chodzi o pierwszą linijkę. Tam gdzie masz Name: coś/coś. Na tej podstawie zmień nazwy folderów i wgraj na serwer powinno trybić ;

Kris8
Posty: 3
Rejestracja: 15 lutego 2018, 19:07

Re: Forum nie czyta nieoficjalnych rozszerzeń.

Post autor: Kris8 » 15 lutego 2018, 19:28

Witam,

po wgraniu do .ext rozszerzenia Ajax Chat (pobrany z phpbb.com) i poprawnym wyświteniu się w panelu admistracyjnym/dostosowanie i włączeniu, następnie po przejściu na stronę główną założonego forum wyświetla się cała biała strona.
Co może blokować wyświetlenie się poprawnie forum ?

vader
Moderator
Posty: 584
Rejestracja: 19 kwietnia 2015, 14:44
Lokalizacja: Kraków
Kontakt:

Re: Forum nie czyta nieoficjalnych rozszerzeń.

Post autor: vader » 16 lutego 2018, 07:19

Jakieś błędy w konsoli przeglądarki (pod F12)? Sprawdź logi hostingu.

Kris8
Posty: 3
Rejestracja: 15 lutego 2018, 19:07

Re: Forum nie czyta nieoficjalnych rozszerzeń.

Post autor: Kris8 » 16 lutego 2018, 12:03

W konsoli jest tylko komunkat typu: Kodowanie znaków w dokumencie HTML nie zostało zadeklarowane.
Logi to nie bardzo wiem czy wyczytam coś z nich.
Na tym samym hostingu miałem zrobione próbne forum i działał ten czat i inne wtyczki.
Obecie mam włączone kikla wtyczek, ale po ich uruchomienie strona wczytywałała się poprawnie.
Czy ma znaczenie to, że wcześniej na tym próbnym forum miałem adres htts:// ... a teraz mam https:// ... . ?

Kris8
Posty: 3
Rejestracja: 15 lutego 2018, 19:07

Re: Forum nie czyta nieoficjalnych rozszerzeń.

Post autor: Kris8 » 26 lutego 2018, 13:57

Z adresem http i https nie ma znaczenia.
Zainstalowałem od nowa forum i wgrałem Ajax czat i nadal po wylogowaniu z Panelu administracyjnego wyświetla się biała strona.
Chyba wersja 3.2.1 nie różni się bardzo od 3.2.2 aby ten czat działał . Bo na 3.2.1 włączył się normalnie i działał.
Czy po wyczyszczeniu bufora co jest w opcjach Panelu i usunięciu plików z katalogu Cache na serwerze, można coś jeszcze wyczyścić z ustawień phpbb ?

vader
Moderator
Posty: 584
Rejestracja: 19 kwietnia 2015, 14:44
Lokalizacja: Kraków
Kontakt:

Re: Forum nie czyta nieoficjalnych rozszerzeń.

Post autor: vader » 26 lutego 2018, 14:47

Co do logów to możesz wkleić je tutaj. Szukałeś na forum phpbb problemów z tym? Biała strona zazwyczaj związana jest z błędem HTTP 500 i w logach powinna być informacja dlaczego tak się dzieje.

lalanablanalala
Posty: 9
Rejestracja: 04 kwietnia 2018, 21:19

Re: Forum nie czyta nieoficjalnych rozszerzeń.

Post autor: lalanablanalala » 04 kwietnia 2018, 21:25

Witam. Dzisiaj wrzuciłem rozszerzenie na dysk dwoma metodami
Moja strona / ext / autogroups?

Moja strona / ext / phpbb / autogroups?

lecz w ogóle nie pojawia mi się rozszerzenie na liście... Wszystkie inne zawsze mi się pojawiały.
Mam forum 3.2.1 i planuje ongiś wgrać 3.2.2 tak jak jest w waszym poradniku http://www.phpbb.pl/viewtopic.php?f=138&t=17906
Mam nadzieję że mi się uda. Jeszcze będę musiał ogarnąć jak robi się kopię bazy danych aby je znowu nie wgrywać kiedy coś nie wyjdzie.

Mam pytanie jak zrobić takie zabezpieczenie jak jest u was z ta zupa pomidorowa? :p

vader
Moderator
Posty: 584
Rejestracja: 19 kwietnia 2015, 14:44
Lokalizacja: Kraków
Kontakt:

Re: Forum nie czyta nieoficjalnych rozszerzeń.

Post autor: vader » 05 kwietnia 2018, 07:16

lalanablanalala pisze:
04 kwietnia 2018, 21:25
Witam. Dzisiaj wrzuciłem rozszerzenie na dysk dwoma metodami
Moja strona / ext / autogroups?

Moja strona / ext / phpbb / autogroups?

lecz w ogóle nie pojawia mi się rozszerzenie na liście... Wszystkie inne zawsze mi się pojawiały.
Mam forum 3.2.1 i planuje ongiś wgrać 3.2.2 tak jak jest w waszym poradniku http://www.phpbb.pl/viewtopic.php?f=138&t=17906
Mam nadzieję że mi się uda. Jeszcze będę musiał ogarnąć jak robi się kopię bazy danych aby je znowu nie wgrywać kiedy coś nie wyjdzie.

Mam pytanie jak zrobić takie zabezpieczenie jak jest u was z ta zupa pomidorowa? :p
1. Fajnie jakbyś podał nazwę / link do rozszerzenia zanim o coś pytasz. https://www.phpbb.com/customise/db/exte ... to_groups/
powinno zadziałać z Moja strona / ext / phpbb / autogroups

2. Aktualizacja http://www.phpbb.pl/forum/viewtopic.php?f=138&t=18062

3. ACP > Ogólne > Zabezpieczenie antyspamowe > Wtyczka Q&A - ustawiasz pytanie

ODPOWIEDZ