Otwieranie strony w nowym oknie 2

Forum przeznaczone dla osób poszukujących modyfikacji do phpBB 3.0.x oraz ich polskich lokalizacji.
Muffi
Posty: 41
Rejestracja: 03 stycznia 2015, 18:27

Otwieranie strony w nowym oknie 2

Post autor: Muffi » 13 kwietnia 2015, 10:35

Witam

Zakładam ponownie temat, ponieważ poprzedni został zamknięty a poszukuję rozwiązania problemu dotyczącego stylu we_clearblue. Stosując się do wytycznych zawartych w tej instrukcji https://www.phpbb.com/support/docs/en/3 ... w-windows/ albo http://www.tworzenie-stron-www.com/link ... wym-oknie/ napotkałem następujące przeszkody:

-W stylu we_clearblue w katalogu template nie ma pliku bbcode.html
-W podkatalogu includes/functions.php (phpbb ver. 3.0.12) nie posiadam kodu:

Kod: Zaznacz cały

     case 'bbcode_htm':
         return array(
            '#<!\-\- e \-\-><a href="mailto:(.*?)">.*?</a><!\-\- e \-\->#',
            '#<!\-\- l \-\-><a (?:class="[\w-]+" )?href="(.*?)(?:(&|\?)sid=[0-9a-f]{32})?">.*?</a><!\-\- l \-\->#',
            '#<!\-\- ([mw]) \-\-><a (?:class="[\w-]+" )?href="(.*?)">.*?</a><!\-\- \1 \-\->#',
            '#<!\-\- s(.*?) \-\-><img src="\{SMILIES_PATH\}\/.*? \/><!\-\- s\1 \-\->#',
            '#<!\-\- .*? \-\->#s',
            '#<.*?>#s',
         );
który powinienem zmienić na:

Kod: Zaznacz cały

      case 'bbcode_htm':
         return array(
            '#<!\-\- e \-\-><a href="mailto:(.*?)">.*?</a><!\-\- e \-\->#',
            '#<!\-\- l \-\-><a (?:class="[\w-]+" )?href="(.*?)(?:(&|\?)sid=[0-9a-f]{32})?" onclick="window\.open\(this\.href\);return false;">.*?</a><!\-\- l \-\->#',
            '#<!\-\- ([mw]) \-\-><a (?:class="[\w-]+" )?href="(.*?)" onclick="window\.open\(this\.href\);return false;">.*?</a><!\-\- \1 \-\->#',
            '#<!\-\- s(.*?) \-\-><img src="\{SMILIES_PATH\}\/.*? \/><!\-\- s\1 \-\->#',
            '#<!\-\- .*? \-\->#s',
            '#<.*?>#s',
         );
Bardzo proszę o pomoc w poradzeniu sobie z tymi przeszkodami....

Pozdrawiam

Aviator
Administrator
Posty: 2089
Rejestracja: 07 czerwca 2011, 22:14
Lokalizacja: ZS

Re: Otwieranie strony w nowym oknie 2

Post autor: Aviator » 13 kwietnia 2015, 13:01

1. W stylu Prosilver jest bbcode.html, poczytaj o stylach z rodzicem.
2. Szukaj jakiegoś fragmentu z tego kodu.
-=Jeżeli w moim poście brakuje znaków diakrytycznych, oznacza to, że posta wyklepałem przez telefon=-

Muffi
Posty: 41
Rejestracja: 03 stycznia 2015, 18:27

Re: Otwieranie strony w nowym oknie 2

Post autor: Muffi » 16 kwietnia 2015, 09:36

Witam

Dziękuję za odzew ale nic z tego nie rozumiem.

1.Oczywiście, zgadza się że w stylu Prosilver jest bbcode.html tylko jak to wykorzystać...?
2. Niestety, ale nawet fragmentu tego kodu nie ma w podkatalogu includes/functions.php (phpbb ver. 3.0.12)

Jeżeli ktoś konkretnie może wskazać co można zrobić, to bardzo będę wdzięczny...

Pozdrawiam

Aviator
Administrator
Posty: 2089
Rejestracja: 07 czerwca 2011, 22:14
Lokalizacja: ZS

Re: Otwieranie strony w nowym oknie 2

Post autor: Aviator » 16 kwietnia 2015, 19:43

Muffi pisze:Dziękuję za odzew ale nic z tego nie rozumiem.
Aviator pisze:1. W stylu Prosilver jest bbcode.html, poczytaj o stylach z rodzicem.
Poczytałeś czy lenistwo?
Jeżeli posiadasz styl dziedziczony z Prosilver i plików których nie posiadasz w swoim stylu a są w prosilver to edytujesz w Prosilver.


Otworzyłem plik includes/functions.php w wersji phpbb 3.0.12 i o dziwo jest ten kod w całej okazałości.
Juz temat miałem zamknąć za brak zaangażowania z Twojej strony, ale masz jeszcze szanse.
nl.JPG
(175.17 KiB) Pobrany 34195 razy
-=Jeżeli w moim poście brakuje znaków diakrytycznych, oznacza to, że posta wyklepałem przez telefon=-

Muffi
Posty: 41
Rejestracja: 03 stycznia 2015, 18:27

Re: Otwieranie strony w nowym oknie 2

Post autor: Muffi » 17 kwietnia 2015, 11:41

Witam

Przepraszam za brak aktywności. Kod faktycznie jest. Nie wiem dlaczego nie mogłem go znaleźć, zapewne zmęczenie dało w kość. Na drugi raz będę bardziej uważał. Wykonałem wszystkie modyfikacje, we wszystkich plikach i nie ma żadnego efektu. Linki tak jak się otwierały w tym samym oknie, tak dalej się otwierają. Zmieniłem nawet styl na prosilver, ażeby sprawdzić czy czasami nie jest to wina samego stylu we_clearblue, ale nic nie pomogło. W załączniku dołączyłem pliki które zmodyfikowałem według metody opisanej pod tym linkiem:https://www.phpbb.com/support/docs/en/3 ... w-windows/ Naprawdę nie wiem co może być nie tak. Jeżeli jest możliwość i chęci zajrzenia do tych modyfikacji to będę bardzo wdzięczny

Pozdrawiam
Załączniki
Orginal.zip
(49.81 KiB) Pobrany 142 razy
Modyfikacja.zip
(49.95 KiB) Pobrany 145 razy

Muffi
Posty: 41
Rejestracja: 03 stycznia 2015, 18:27

Re: Otwieranie strony w nowym oknie 2

Post autor: Muffi » 17 kwietnia 2015, 16:54

Witam

Zauważyłem, że otwierają się tylko te linki w innym oknie, które zostają zamieszczone w poście i oznaczone jako URL. Czy można zrobić tak, ażeby załączniki JPG otwierały się w osobnej karcie przeglądarki...?

Pozdrawiam

Aviator
Administrator
Posty: 2089
Rejestracja: 07 czerwca 2011, 22:14
Lokalizacja: ZS

Re: Otwieranie strony w nowym oknie 2

Post autor: Aviator » 17 kwietnia 2015, 19:09

Odswiezyles style, swoj i prosilver wyczysciles cache?
-=Jeżeli w moim poście brakuje znaków diakrytycznych, oznacza to, że posta wyklepałem przez telefon=-

Muffi
Posty: 41
Rejestracja: 03 stycznia 2015, 18:27

Re: Otwieranie strony w nowym oknie 2

Post autor: Muffi » 18 kwietnia 2015, 09:36

Witam

Tak. Odświeżyłem wszystkie style, ale to nic nie pomaga...

Zablokowany