[Aktualizacja 3.0.12] - pytania

Pomoc w przypadku kłopotów z modyfikacjami: instalacją, konfiguracją, błędami. Zakładając nowy temat pamiętaj o odpowiednim prefiksie!
Regulamin forum Na tym forum wymagane jest stosowanie prefiksów w tytułach tematów. Prefiks tematu musi składać się nazwy modyfikacji, której dotyczy problem. Dla modyfikacji phpBB Gallery poprawna nazwa tematu to przykładowo [phpBB Gallery] Problem z wgrywaniem zdjęć. Tematy niespełniające wymogu będą przenoszone do kosza.
  • Autor
  • Wiadomość
Offline

ElsieMarina

  • Posty: 2
  • Rejestracja: 30 września 2016, 22:08

[Aktualizacja 3.0.12] - pytania

Post30 września 2016, 22:18

Witam wszystkich serdecznie i bardzo proszę o odpowiedzi na nurtujące mnie pytania.

Mam wersję forum 3.0.12 - czy konieczna jest aktualizacja i instalacja najnowszej wersji? Czytałam, że podobno jeśli tego nie zrobię to forum po czasie będzie mieć problemy z prawidłowym funkcjonowaniem, czy to prawda?

Chciałam aktualizować forum, ale nie udaje mi się. Z tego co czytałam to powinnam robić to po kolei - czyli teraz wersje 3.0.14. Natomiast na stronie phpbb w zakładce Automatic Update najstarsza wersja jaką mogę pobrać to 3.10. Pobrałam ja i wgrałam katalog install oraz uruchomiłam automatyczna aktualizację, która jednak nie działa... czy to oznacza, że muszę szukać najpierw 3.0.14?

Czy po jakiejkolwiek aktualizacji forum, muszę na nowo ustawiać szatę graficzną i wszystkie inne dodatki i parametry, które wcześniej już zmodyfikowałam?
Offline
Awatar użytkownika

Zyleta

Moderator

  • Posty: 196
  • Rejestracja: 03 marca 2014, 15:39

Re: [Aktualizacja 3.0.12] - pytania

Post01 października 2016, 00:56

ElsieMarina pisze:Mam wersję forum 3.0.12 - czy konieczna jest aktualizacja i instalacja najnowszej wersji? Czytałam, że podobno jeśli tego nie zrobię to forum po czasie będzie mieć problemy z prawidłowym funkcjonowaniem, czy to prawda?


Jeśli obecnie forum funkcjonuje bez problemów, w przyszłości też powinno - chyba że będzie to odległa przyszłość i serwer na którym posiadasz forum przestanie wspierać bazę MySQL w wersji którą wspiera phpbb 3.0.12. Aktualizacja do wersji 3.0.14 nie jest obowiązkowa - poprawia jedynie (z tego co mi się wydaje) pewne luki bezpieczeństwa i jest zalecana, jeśli boisz się o jakiś atak na swoją stronę (jest to spora strona, ze sporą ilością użytkowników, postów, ogółem danych - taka by zachęcała potencjalnych przestępców do ataku).

ElsieMarina pisze:Chciałam aktualizować forum, ale nie udaje mi się. Z tego co czytałam to powinnam robić to po kolei - czyli teraz wersje 3.0.14. Natomiast na stronie phpbb w zakładce Automatic Update najstarsza wersja jaką mogę pobrać to 3.10. Pobrałam ja i wgrałam katalog install oraz uruchomiłam automatyczna aktualizację, która jednak nie działa... czy to oznacza, że muszę szukać najpierw 3.0.14?


Widocznie nie zauważyłaś, że ciut powyżej zakładki "Automatic Update", po prawej stronie jest możliwość wyboru wersji do jakiej chcesz aktualizować - Ciebie będzie interesowało 3.0. Tam wybierasz potem swoją wersję forum, czyli 3.0.12 - poniżej link

https://www.phpbb.com/downloads/3.0/?mo ... ion=3.0.12

PS nie ma potrzeby robienia tego po kolei, ważne żeby wybrać update z Twojej aktualnej wersji, do tej docelowej - wtedy wszystko będzie tak jak być powinno.

ElsieMarina pisze:Czy po jakiejkolwiek aktualizacji forum, muszę na nowo ustawiać szatę graficzną i wszystkie inne dodatki i parametry, które wcześniej już zmodyfikowałam?


W przypadku aktualizacji z 3.0.12 na 3.0.14 (czy jakiejkolwiek innej z 3.0.x na 3.0.y) nie ma takiej potrzeby - ewentualnie ręczna modyfikacja niektórych elementów obecnego stylu według zmian jakie nastały w ich ogólnej budowie.

W przypadku aktualizacji z wersji 3.0.12 na 3.1.9 (czy jakiejkolwiek innej z 3.0.x na 3.1.y) jest to problematyczne - musiałabyś usunąć wszelkie modyfikacje jakie wgrałaś i niekoniecznie wszystkie byłyby dostępne na wersję 3.1, więc możliwe że z częścią z nich byś się pożegnała na stałe. Styl również by musiał być dopasowany do nowej wersji forum, co wiąże się z niezliczoną ilością zmian i byłoby bardzo kosztowne w czasie (chyba że ów styl nie jest Twojego autorstwa, tylko osoby która go udostępniła i stworzyła ten sam styl, albo podobny pod nową wersję forum, wtedy byś musiała odinstalować obecny styl i wgrać nowy - ewentualne własne zmiany w nim robić już na własną rękę).
Dlatego, jeśli sporo zmian masz na swoim forum (modów, zmian własnego autorstwa, własny styl), odradzałbym przechodzenia na wersję 3.1 bez wcześniejszego przygotowania (co jak wspominałem, jest bardzo kosztowne w czasie - ewentualne zlecenie komuś tej roboty to byłoby zapewne spore obciążenie portfela - w zależności ile tego byłoby do zmiany). 3.0.14 powinno wystarczyć (3.0.12 też powinno wystarczyć).

Jedyne czego możesz się obawiać, zostawiając starszą wersję forum, to to, że nie będzie ona dalej rozwijana przez twórców, co za tym idzie, będziesz narażona na wszelkie nowe zagrożenia ze strony cyberprzestępców i to już będzie zależało od atrakcyjności Twojej strony, czy masz się czego obawiać, czy też nie ;)

Trochę długi wywód, bardziej własna opinia, niepoparta doświadczeniem, więc polecałbym również poczekać na odpowiedź kogoś bardziej obeznanego w temacie ;)
Offline

ElsieMarina

  • Posty: 2
  • Rejestracja: 30 września 2016, 22:08

Re: [Aktualizacja 3.0.12] - pytania

Post01 października 2016, 11:49

Wow dziękuje za dokładną i wyczerpującą odpowiedź :D Teraz już wiem, że jednak nie będę przechodziła na tą wersje 3.1 :D Jeszcze raz bardzo dziękuje! To wszystko bardzo mi pomogło i rozwiało moje wątpliwości.

Wróć do Pomoc

Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 3 gości