utf_tools.php on line 1663

Dyskusje na temat modyfikowania i tworzenia stylów do phpBB 3.0.x oraz spraw związanych z szablonami, motywami i zestawami obrazków.
Awatar użytkownika
kynval
Posty: 133
Rejestracja: 13 lutego 2009, 09:37
Kontakt:

utf_tools.php on line 1663

Post autor: kynval » 15 grudnia 2014, 18:53

Witam...
mam forum phpbb 3.0.5 od wielu lat i wszystko było pięknie...
nagle wyskoczył mi taki błąd:
Strict Standards: Non-static method utf_normalizer::nfkc() should not be called statically in /usr/home/templars/domains/templars.2ap.pl/public_html/includes/utf/utf_tools.php on line 1663 Strict Standards: Non-static method utf_normalizer::nfkc() should not be called statically in /usr/home/templars/domains/templars.2ap.pl/public_html/includes/utf/utf_tools.php on line 1663 Strict Standards: Non-static method utf_normalizer::recompose() should not be called statically in /usr/home/templars/domains/templars.2ap.pl/public_html/includes/utf/utf_normalizer.php on line 177

Awatar użytkownika
kynval
Posty: 133
Rejestracja: 13 lutego 2009, 09:37
Kontakt:

Re: utf_tools.php on line 1663

Post autor: kynval » 15 grudnia 2014, 22:15

wyskauje na innych stronach również to:

Strict Standards: Only variables should be passed by reference in /usr/home/templars/domains/templars.2ap.pl/public_html/includes/arcade/functions_arcade.php on line 642
a ta linia wygląda tak:

Kod: Zaznacz cały

		$leader_id = array_shift(array_keys($highscore_data));

Awatar użytkownika
Bielu
Administrator
Posty: 511
Rejestracja: 17 marca 2011, 07:49
Kontakt:

Re: utf_tools.php on line 1663

Post autor: Bielu » 15 grudnia 2014, 22:57

zmieniła ci się wersja php na serwerze :), bo innego rozwiązania nie widzę :)
Uwaga! pomoc poza forum jest odpłatna!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Pomogłem? Podziękuj, dając like: https://www.facebook.com/webdeveloperbielu
=====================
Kodowanie styli, modowanie phpbb3 oraz innych skryptów: Webdeveloper Bielu

Awatar użytkownika
kynval
Posty: 133
Rejestracja: 13 lutego 2009, 09:37
Kontakt:

Re: utf_tools.php on line 1663

Post autor: kynval » 15 grudnia 2014, 23:22

to znaczy, że moja wersja phpbb nie ogarnie tego?
coś mam zmienić?

Awatar użytkownika
Bielu
Administrator
Posty: 511
Rejestracja: 17 marca 2011, 07:49
Kontakt:

Re: utf_tools.php on line 1663

Post autor: Bielu » 15 grudnia 2014, 23:29

zaktualizować ręcznie do 3.0.12 jeśli chcesz zachować mody lub zaktualizować do 3.1 i znów bawić się w dobieranie rozszerzeń
Uwaga! pomoc poza forum jest odpłatna!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Pomogłem? Podziękuj, dając like: https://www.facebook.com/webdeveloperbielu
=====================
Kodowanie styli, modowanie phpbb3 oraz innych skryptów: Webdeveloper Bielu

Zablokowany