HTTP ERROR 500

Pomoc przy instalacji oraz użytkowaniu phpBB 3.2.x. Forum nie służy do zgłaszania znalezionych błędów, innowacji lub problemów związanych ze stylami i rozszerzeniami.
Wazdar
Posty: 20
Rejestracja: 14 sierpnia 2015, 18:58
Kontakt:

HTTP ERROR 500

Post autor: Wazdar » 18 listopada 2019, 14:08

Przekopałem forum ale takiej sytuacji nie było.
Pewnego dnia forum się wywaliło i pokazuje takie błąd - nic nie było robione (chyba, że ktoś z adminów forum coś zrobił).
Sprawdziłem wszystko co w takich sytuacjach sprawdzam:
- plik .htcess po zmianie nazwy - nadal błąd
- uprawnienia folderów, plików są ok

Wkurzony zrobiłem backup plików z dnia wcześniej gdzie wszystko grało. Błąd nadal występuje.

Serwer na OVH - nikt nie odpowiada na zgłoszenie z panelu klienta :(

Ktoś z Was miał coś takiego? może wiecie jak znaleźć info o błędzie na serwerze?
FESTINA SEO:
Projektowanie stron www, pozycjonowanie, kampanie Google Ads, Social media.

hrx
Posty: 160
Rejestracja: 28 grudnia 2013, 10:47

Re: HTTP ERROR 500

Post autor: hrx » 18 listopada 2019, 22:31

Jakiej wersji PHP używasz?

Wazdar
Posty: 20
Rejestracja: 14 sierpnia 2015, 18:58
Kontakt:

Re: HTTP ERROR 500

Post autor: Wazdar » 19 listopada 2019, 07:21

Miałem zainstalowaną wersje 7.0 na serwerze i wszystko pięknie działało. Też myślałem, że to to i podniosłem do 7.3 i też nic.
Support z OVH od soboty nie odpowiedział na zgłoszenie :(
FESTINA SEO:
Projektowanie stron www, pozycjonowanie, kampanie Google Ads, Social media.

Wazdar
Posty: 20
Rejestracja: 14 sierpnia 2015, 18:58
Kontakt:

Re: HTTP ERROR 500

Post autor: Wazdar » 19 listopada 2019, 10:01

Dobra znalazłem błąd chodzi o nowy styl. Jest błąd, że nie może go znaleźć. Jak mogę zmienić styl na inny w kodzie? bo do panelu też nie mogę wejść.
Usuwanie szablonu z błędem nic nie daje bo jest ustawiony jako domyślny. Czy jak zmienię w kodzie domyślny szablon na podstawowy to forum wróci?

Taki to jest błąd:

Kod: Zaznacz cały

Fatal error: Uncaught Twig\Error\LoaderError: Unable to find template "index_body.html" (looked into: /home/amatorsk/www/forum/styles/all/template). in /home/amatorsk/www/forum/vendor/twig/twig/src/Loader/FilesystemLoader.php:245 Stack trace: #0 /home/amatorsk/www/forum/phpbb/template/twig/loader.php(135): Twig\Loader\FilesystemLoader->findTemplate('index_body.html') #1 /home/amatorsk/www/forum/vendor/twig/twig/src/Loader/FilesystemLoader.php(155): phpbb\template\twig\loader->findTemplate('index_body.html') #2 /home/amatorsk/www/forum/vendor/twig/twig/src/Environment.php(351): Twig\Loader\FilesystemLoader->getCacheKey('index_body.html') #3 /home/amatorsk/www/forum/vendor/twig/twig/src/Environment.php(445): Twig\Environment->getTemplateClass('index_body.html') #4 /home/amatorsk/www/forum/phpbb/template/twig/environment.php(277): Twig\Environment->loadTemplate('index_body.html', NULL) #5 /home/amatorsk/www/forum/vendor/twig/twig/src/Environment.php(423): phpbb\template\twig\environment->loadTemplate('index_body.html') #6 /h in /home/amatorsk/www/forum/vendor/twig/twig/src/Loader/FilesystemLoader.php on line 245
FESTINA SEO:
Projektowanie stron www, pozycjonowanie, kampanie Google Ads, Social media.

Wazdar
Posty: 20
Rejestracja: 14 sierpnia 2015, 18:58
Kontakt:

Re: HTTP ERROR 500

Post autor: Wazdar » 19 listopada 2019, 12:33

Wiem, że nie powinno się dawać post pod postem ale wrzuciłem brakujące pliki. Forum wróciło. Trochę się posypało ale reaktywuje. Usunąłem style i dodatki. Instaluje jeszcze raz.

Pytanie brzmi bo co jakiś czas w PA u góry mam takie błędy:

Kod: Zaznacz cały

[phpBB Debug] PHP Warning: in file [ROOT]/vendor/zendframework/zend-stdlib/src/ArrayObject.php on line 426: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"?
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/zendframework/zend-code/src/Reflection/MethodReflection.php on line 272: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"?
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/zendframework/zend-code/src/Reflection/MethodReflection.php on line 275: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"?
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/zendframework/zend-code/src/Reflection/MethodReflection.php on line 281: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"?
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/zendframework/zend-code/src/Reflection/MethodReflection.php on line 287: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"?
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/zendframework/zend-code/src/Reflection/MethodReflection.php on line 296: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"?
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/zendframework/zend-code/src/Reflection/MethodReflection.php on line 314: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"?
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/zendframework/zend-code/src/Reflection/MethodReflection.php on line 319: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"?
FESTINA SEO:
Projektowanie stron www, pozycjonowanie, kampanie Google Ads, Social media.

Wazdar
Posty: 20
Rejestracja: 14 sierpnia 2015, 18:58
Kontakt:

Re: HTTP ERROR 500

Post autor: Wazdar » 20 listopada 2019, 07:29

Dobra poradziłem sobie :) temat do zamknięcia.

Forum generowało dużo błędów w PHP więc wyrzuciłem wszystko oprócz plików jak przy aktualizacji. Zainstalowałem najnowszą wersje i świeży phpBB działa jak dawniej :D
FESTINA SEO:
Projektowanie stron www, pozycjonowanie, kampanie Google Ads, Social media.

vader
Moderator
Posty: 985
Rejestracja: 19 kwietnia 2015, 14:44
Lokalizacja: Kraków
Kontakt:

Re: HTTP ERROR 500

Post autor: vader » 20 listopada 2019, 08:26

Fajnie że się udało rozwiązać problemy. Ale skoro się udało, to warto napisać, gdzie leżała przyczyna. Być może komu się to przyda :)

Wazdar
Posty: 20
Rejestracja: 14 sierpnia 2015, 18:58
Kontakt:

Re: HTTP ERROR 500

Post autor: Wazdar » 08 stycznia 2020, 13:29

vader pisze:
20 listopada 2019, 08:26
Fajnie że się udało rozwiązać problemy. Ale skoro się udało, to warto napisać, gdzie leżała przyczyna. Być może komu się to przyda :)
Napisałem w moim poście wyżej co zrobiłem :)
FESTINA SEO:
Projektowanie stron www, pozycjonowanie, kampanie Google Ads, Social media.

ODPOWIEDZ